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5-14 ICT in Learning & Teaching

Controlling and Modelling - Roamer

	Teacher Guide


	Attainment Target
	· Plan a sequence of instructions to be executed by a device


	Exemplification of Strand
	· Use the keyboard and mouse to operate fully a software application.

· Use a control software application with repeat/loop/procedure commands to make a basic pattern on screen and print the results.


	Resources Needed
	· RM Window box PC
· Software Roamer World
· Roamer Floor turtle
· Roamer Pen Kit (Optional)
· Roamer PC Interface Kit (Optional)

	Outline of Activites
(7 Activities)
	Activity 1: Singing Roamer
This activity introduces the features of Music and Wait. The children enter a set of instructions and watch what happens when Roamer carries them out.  The children then have to write their own instructions. 
Activity 2: Making Roamer Wait and Sing
The children are given 3 diagrams and 3 sets of instructions. They have to match each diagram to a set of instructions. 

Activity 3: Writing and Saving Procedures
A Procedure is a set of instructions that can be programmed into Roamer and then inserted into a set of instructions to save entering it every time.  Procedures must be entered in a certain way to be stored. 
PLEASE NOTE: If you switch Roamer off then you will LOSE any Procedures already entered.  See activity 6.
Activity 4: Using Sound and Wait with Roamer World

Pupils write their own instructions using Wait, Music and Repeat.  If no sounds can be heard when the Go Program is run check that the sound option is on. Click on:  Options > Sound.
Activity 5: Writing and Saving Procedures with Roamer World

Roamer World can save up to 99 different procedures.  Be careful that you do not delete procedures that other people are still using.
Activity 6: Using Roamer and Roamer World Together
Procedures can be transferred to the PC, or vice versa, via a PC Interface Kit.  This can be bought as an optional extra.  This is a cable that connects between the PC and Roamer.  When connected you can transfer a Go Program by clicking Floor Roamer > Send Go Program.  

Activity 7: Roamer and Roamer World Challenge

The pupils write two procedures and use these in a set of instructions on screen with Roamer World.  They should then transfer the Go Program to Roamer and see if the same pattern is produced.



	In this activity you will learn to:

· make Roamer Wait and Sing.
· write and save Procedures using Roamer.



Activity 1: Singing Roamer
You have used Roamer to carry out all sorts of activities.  We are going to use two of Roamer’s other features we have not used yet.
1. Enter these instructions into your Roamer and watch what happens.

	CM  CM

♪ 44

FD 2

RT 90

♪ 44

FD2

RT 90
	W 5

FD 2

RT 90

♪  44

FD 2

RT 90

♪ 44

GO
	Draw what Roamer does.
	Write down what you noticed.


2. What do you think the ♪ 

makes Roamer do? 
    …………………………………………………………..
What do you think the W
makes Roamer do? 
    …………………………………………………………..
Your challenge:
Write a set of instructions that will make Roamer make a shape where he makes a noise at each corner and waits for a few seconds at each corner before going on.
	My Shape
	My instructions

	
	
	


	In this activity you will learn to:

· make Roamer Wait and Sing.
· write and save Procedures using Roamer.



Activity 2: Making Roamer Wait and Sing!
Look at the three sets of instructions and the three diagrams.  Can you match which set of instructions goes with which diagram?  Use Roamer to help you decide.

	Diagram 1

	Diagram 2
	Diagram 3

	   ♪             ♪♪♪            ♪
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    ♪              ♪              ♪
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	Instructions 1
	Instructions 2
	Instructions 3

	CM CM
FD 3

RT 90

♪ 26

FD  2

♪ 26

RT 90

FD 1

RT  90

♪  26

	FD  4
♪  26

RT 90

FD 1
♪  26
RT 90
FD 2
♪  26
GO

	CM  CM
BK  3

♪  23

LT  90

FD 2

♪ 33

RT  90

FD  2

♪  42

RT  90

FD  2
	♪  33
FD 2

RT  90

♪ 43

FD  2

♪  33

RT  90

FD  2

♪  34

GO
	CM  CM
♪  32

FD 2

♪ 12

LT 90

FD 2

♪ 32

LT 90

FD 2

♪12

LT 90

	FD 4

LT 90
♪ 32

FD 2

LT  90

♪ 12

FD 2

♪  12

♪  32

GO


Diagram 1



Instructions 1

Diagram 2



Instructions 2

Diagram 3



Instructions 3

Make your own instructions that use the WAIT, MUSIC and REPEAT functions to make Roamer produce an interesting pattern.
	In this activity you will learn to:

· write and save Procedures using Roamer.



Activity 3: Writing and Saving a Procedure

A Procedure is a set of instructions that you can enter into Roamer that he will remember as long as he is switched on.  You can use a Procedure to save a complicated routine so that all the instructions do not need to be entered every time you want to use it.

1. Enter the instructions for the Procedure below into Roamer.  This procedure will now be stored in his memory.  He won’t carry out the procedure until you give him the instruction to do so.  Use the instructions on the right to see what he does.
DO NOT switch Roamer off during this exercise or the procedure will be lost.
	Procedure
	Pattern
	Instructions

	CM  CM 

P  1  [

         FD 1

         ♪ 22

          FD 1

          ♪  23

          BK  2

          ♪  22

           RT 90

           ]

CM  CM
	[image: image7.wmf]

	CM  CM
R  4 [

        P  1

        ]

GO


Roamer can remember up to 99 procedures.  However, when you switch him off he will forget these.  (More about this later.)

A Procedure must be written in a certain way.
	CM  CM

P

3

[

R 4 [

       FD  2

       RT  9O

       ]

RT 45

]

CM     CM
	Clears all the memory in Roamer
Tells Roamer it is a Procedure
This will be Procedure number 3

The procedure is written within brackets
Repeat 4 times what is in the brackets
Go Forward 2

Turn Right 90º

Close the Repeat brackets
Turn Roamer  45º

Close the Procedure brackets

Clears all the memory in Roamer



2. Now use the procedure in a Go Program to make Roamer produce a pattern by entering the instructions below.  Draw the pattern that Roamer makes.
	Instructions 
	Pattern Made
	You can see how much easier it is to use a procedure to program Roamer.
Make sure you remember which number you gave to your procedure.  Use one that has not been used already.


	CM  CM  

R  8  [

         P  1

         ]

GO


	
	


Writing a Procedure
3. Write and enter 2 procedures into the memory of Roamer.  After you enter each one remember to press CM twice.
	Procedure a
	Procedure b

	CM  CM

P  ……..     [

                  …………….

                  …………….

                  …………….

                  …………….

                  …………….

                  …………….

                  ]

CM   CM
	CM  CM

P  ……..     [

                  …………….

                  …………….

                  …………….

                  …………….

                  …………….

                  …………….

                  ]

CM   CM



4. Enter the following into Roamer and watch what he does closely. Draw what Roamer does on the back of this sheet.
	CM    CM

FD   2

[image: image8.emf]RT 90

P  a**…….   


	BK  2

LT  90

P  b**
FD 1

GO
	**  Use the number of the procedure above when you enter the procedures where a** and b** are.


	In this activity you will learn to:

· make Roamer Wait and Sing.
· write and save Procedures using Roamer.




Activity 4: Using Sound and Wait with Roamer World
You can make Roamer make sounds and wait before moving.
1. Enter these instructions using Roamer World and watch what happens.  Save the Working Area when you have done each one.  


File> Save Working Area   >  Name File > Click on Save
	Example 1
	
	Example 2

	CM   CM

PD  BLACK

FD 2

RT 90

♪  45

W  4

FD 2 

RT  90

♪  45

FD 2
	W  5

♪   45

♪   46

♪   48

W2

♪   410

RT 90

FD 2

♪   412

♪   413

GO 
	
	CM   CM
♪  42

♪  44

PD RED

R  4 [

        FD 2

        RT 90

        ♪  46

        W 5

        ]
	FD 2
R  4 [

        PD BLUE

        FD 2

        LT 90

        ♪  46

        W  5

        ]

GO


2. Now make your own pattern which uses wait, music and repeats and save your work.

	INSTRUCTIONS
	PICTURE

	
	
	


	In this activity you will learn to:

· write and save Procedures using Roamer.




Activity 5: Writing and Saving Procedures Using Roamer World

As you found out with the floor Roamer you can program Procedures which mean you do not have to type in lots of instructions every time you want to use a pattern you have used before.  Roamer World can save up to 99 procedures in its memory and will not forget them when you switch it off.

1. [image: image9.emf]Enter P1 [ into the Go Program area and a new box will appear on screen.  This is the PROCEDURE box.

2. If the Procedure number has been used already an extra box will appear.  Click on No and click CE on the control panel and enter a procedure with a new number e.g. P 3 [
3. When you enter the instructions they will appear in the Procedures box and you will hear a different beep.
4. You can list instructions or use the Repeat function in a procedure.
When you finish your Procedure:
Minimise the Procedure window.

Check the Procedure works.

Enter the instruction ‘P ……’ and Go.
Now you can use your procedure in a list of instructions e.g.

FD 3

PD RED

RT 90

P1

FD 2
LT 90

P 2

PU

GO
Experiment with writing procedures and using them as part of your program.
	In this activity you will learn to:

· transfer Go Programs from the computer to a floor Roamer.



Activity 6: Using Roamer and Roamer World Together

If you have a Roamer PC Interface Pack then you can enter your instructions on the computer in Roamer World and then transfer them to your floor Roamer and he will carry them out.
1. Open Roamer World on the PC.
2. Enter instructions into the Go Program area of the screen.
3. Test the program out on the screen and make any changes needed.

4. Connect your interface cable to the PC and to your Roamer.
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5. To transfer the Go Program from the PC to Roamer:
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Now press Go on your floor Roamer and off he should go!

Do not send programs to Roamer where you ask him to move long distances as you may not have enough space!
	In this activity you will learn to:

· transfer Go Programs from the computer to a floor Roamer.



Activity 7: Roamer & Roamer World Challenge
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After all the work you have done with Roamer and Roamer World can you put it all together and produce one piece of work?
Your  Challenge!

1. Write TWO procedures that will make nice patterns.
2. Write a set of instructions that include both procedures and check that it works on the screen.
3. Use the PC Interface cable to transfer your Go Program from the computer to the floor Roamer.

4. Get Roamer to follow the instructions by pressing Go.
5. Save your Go Program from Roamer World and print out the Working Area as a record of what you did.
[image: image14.emf]
Answers to Activities at Stage 7

	Activity 1 Singing Roamer

1. Roamer makes a SQUARE.

    You should notice that he 
    ‘beeps’ at certain points and 
    waits between instructions.
2. ♪   It makes ‘Roamer’ beep

    W    This makes ‘Roamer’ wait


	Activity 2  Wait and Sing
Diagram 1 –   Instructions   3

Diagram 2 –   Instructions   1

Diagram 3  -   Instructions   2

	Activity 3 Write & Save Procedures
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Q 1

	Q 2

	Activity 4 Sound and Wait
1
2 

	


















































Press CM twice on your floor Roamer. 








Click on: Floor Roamer > Send Go Program





Wait for a message to tell you that the program has been sent.  Disconnect the cable.











                    ♪





   ♪               ♪               ♪








   ♪                ♪              ♪ 





♪                  ♪ ♪               ♪








♪                                    ♪            

















© Aberdeenshire Council 2005

                          C&M Roamer Level D Stage 7   V 1.1

6

